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Chapter 1 - Introduction 

About Navicat 

Navicat is a multi-connections Database Administration tool allowing you to connect to MySQL, Oracle, PostgreSQL, 

SQLite and/or MariaDB databases, making database administration to multiple kinds of database so easy. It also can 

manage cloud databases such as Amazon Redshift, Amazon RDS. Features in Navicat are sophisticated enough to 

provide professional developers for all their specific needs, yet easy to learn for users who are new to database server. 

With its well-designed Graphical User Interface(GUI), Navicat lets you quickly and easily create, organize, access and 

share information in a secure and easy way. 

Navicat is available on three platforms - Microsoft Windows, macOS and Linux. It can connect to local/remote servers, 

providing several utility tools such as Navicat Cloud Collaboration, Data Modeling, Data Transfer, Data/Structure 

Synchronization, Import/Export, Backup/Restore and Automation. 

For details, visit our website: https://www.navicat.com 

System Requirements 

Windows 

· Microsoft Windows Vista, Windows 7, Windows 8, Windows 8.1, Windows 10, Server 2008, Server 2008 R2, 

Server 2012, Server 2016 

macOS 

· Mac OS X 10.10 Yosemite, Mac OS X 10.11 El Capitan, macOS 10.12 Sierra, macOS 10.13 High Sierra 

Linux 

· Ubuntu 12.04, Ubuntu 14.04, CentOS 6.7, CentOS 7, Fedora 22, Fedora 23, Linux Mint 13, Linux Mint 17.3, 

openSUSE 13.2, openSUSE 42.1 

Supported On-Premises Databases 

· MySQL 3.23 or above, Drizzle, OurDelta, Percona Server 

· PostgreSQL 7.3 or above 

· Oracle 8i or above 

· SQLite 2 and 3 

· MariaDB 5.1 or above 

Supported Cloud Databases 

Amazon AWS 

https://www.navicat.com/
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· Amazon Redshift 

· Amazon Aurora for MySQL 

· Amazon Aurora for PostgreSQL 

· Amazon RDS for MySQL 

· Amazon RDS for PostgreSQL 

· Amazon RDS for Oracle 

· Amazon RDS for MariaDB 

Google Cloud 

· Google Cloud SQL for MySQL 

· Google Cloud SQL for PostgreSQL 

Oracle Cloud 

· Oracle Database Cloud Service 

· Oracle MySQL Cloud Service 

Installation 

We strongly suggest that you shut down any opened applications. This will help ensure a smooth installation. 

Note: Installing Navicat does not include the server installation. You should download and install the server manually. 

For user who has been trying our unregistered version, just simply key in the Registration Key (16 digit) on the pop up 

Registration screen. 

Installation for Download Version 

1. Download Navicat Linux version. 

2. Extract the gzip file into anywhere you wish. 

3. Open the unzipped folder. 

4. Double-click start_navicat to start your Navicat. Please note that it would take a while for starting-up. 

5. A Registration screen will then pop up, key in the Registration Key (16 digit) and click Activate to online 

activate the key. 

Installation for CD Version 

1. Load the Navicat CD Installation disk into the CD-ROM drive. 
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2. Extract the gzip file into anywhere you wish. 

3. Open the unzipped folder. 

4. Double-click start_navicat to start your Navicat. Please note that it would take a while for starting-up. 

5. A Registration screen will then pop up, key in the Registration Key (16 digit) and click Activate to online 

activate the key. 

Migrate Navicat to new computer 

1. In Navicat, choose File -> Export Connections. The exported file (.ncx) contains all your connection settings. 

2. Backup the exported file (.ncx). 

3. In Navicat, choose Help -> Registration and click Deactivate to online deactivate the key. 

4. Uninstall Navicat from the existing computer. 

5. Re-install Navicat in the new computer. 

6. Open Navicat and choose File -> Import Connections in the new computer. 

When a new connection is being established, Navicat will create a subfolder under Settings Location. Most files are 

stored within this subfolder. To look for the path, right-click the connection and choose Edit Connection -> Advanced 

-> Settings Location. 

Moreover, all your saved profiles are stored under profiles. To look for the path, choose Tools -> Options -> 

Miscellaneous -> Profiles Location. 

Upgrade Navicat 

If you want to upgrade an installed copy of Navicat to the latest release, please choose Help -> Check For Updates to 

start the Updater. It will automatically check your installed version. If there is a new version, simply follow the steps in 

the Updater to upgrade your Navicat. It will replace your previous Navicat and your current settings will remain 

unchanged. 

Or, you can submit your registered email address on the Customer Center to download the latest version installer. 

End-User License Agreement  

Note: For the License Agreement of Navicat Cloud service, please click here. 

IMPORTANT: THIS SOFTWARE END USER LICENSE AGREEMENT ("EULA") IS A LEGAL AGREEMENT 

BETWEEN YOU (EITHER AN INDIVIDUAL OR, IF PURCHASED OR OTHERWISE ACQUIRED BY OR FOR AN 

ENTITY, AN ENTITY) AND PREMIUMSOFT CYBERTECH LTD..READ IT CAREFULLY BEFORE COMPLETING THE 

INSTALLATION PROCESS AND USING THE SOFTWARE. IT PROVIDES A LICENSE TO USE THE SOFTWARE 

https://customer.navicat.com/
http://legal.navicat.com/navicatcloud/NavicatCloudLicenseAgreement.rtf
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AND CONTAINS WARRANTY INFORMATION AND LIABILITY DISCLAIMERS. BY INSTALLING AND USING THE 

SOFTWARE, YOU ARE CONFIRMING YOUR ACCEPTANCE OF THE SOFTWARE AND AGREEING TO BECOME 

BOUND BY THE TERMS OF THIS AGREEMENT. IF YOU DO NOT AGREE TO BE BOUND BY THESE TERMS, 

THEN DO NOT INSTALL THE SOFTWARE AND RETURN THE SOFTWARE TO YOUR PLACE OF PURCHASE. 

THIS EULA SHALL APPLY ONLY TO THE SOFTWARE SUPPLIED BY PREMIUMSOFT CYBERTECH LTD. 

HEREWITH REGARDLESS OF WHETHER OTHER SOFTWARE IS REFERRED TO OR DESCRIBED HEREIN.  

1. Definitions 

a. "Non-commercial Version" means a version of the Software, so identified, for use by i) the individual who is a 

natural person and not a corporation, company, partnership or association or other entity or organization (ii) the 

individual who is a student, faculty or staff member at an educational institution, and (iii) staff of a non-profit 

organization or charity organization only. For purposes of this definition, "educational institution" means a 

public or private school, college, university and other post secondary educational establishment. A non-profit 

organization is an organization whose primary objective is to support an issue or matter of private interest or 

public concern for non-commercial purposes.  

b. "Not For Resale (NFR) Version" means a version, so identified, of the Software to be used to review and 

evaluate the Software, only.  

c. "PremiumSoft" means PREMIUMSOFT CYBERTECH LTD. and its licensors, if any.  

d. "Software" means only the PremiumSoft software program(s) and third party software programs, in each case, 

supplied by PremiumSoft herewith, and corresponding documentation, associated media, printed materials, 

and online or electronic documentation.  

e. "Unregistered version", "Trial version" or "Demo version" means an unregistered copy of the SOFTWARE 

("UNREGISTERED SOFTWARE") which may be used by the USER for evaluation purposes for a period of 

fourteen (14) days following the initial installation of the UNREGISTERED SOFTWARE. At the end of the trial 

period ("TRIAL PERIOD"), the USER must either register the SOFTWARE or remove it from his system. The 

UNREGISTERED SOFTWARE may be freely copied and distributed to other users for their evaluation.  

f. "Navicat Essentials" means a version of the Software, so identified, to be used for commercial purpose.  

2. License Grants 

The licenses granted in this Section 2 are subject to the terms and conditions set forth in this EULA:  

a. Subject to Section 2(b), you may install and use the Software on a single computer; OR install and store the 

Software on a storage device, such as a network server, used only to install the Software on your other 

computers over an internal network, provided you have a license for each separate computer on which the 

Software is installed and run. Except as otherwise provided in Section 2(b), a license for the Software may not 

be shared, installed or used concurrently on different computers.  

b. In addition to the single copy of the Software permitted in Section 2(a), the primary user of the computer on 

which the Software is installed may make a second copy of the Software and install it on either a portable 

computer or a computer located at his or her home for his or her exclusive use, provided that:  

A. the second copy of the Software on the portable or home computer (i) is not used at the same time as 

the copy of the Software on the primary computer and (ii) is used by the primary user solely as allowed 

for such version or edition (such as for educational use only),  
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B. the second copy of the Software is not installed or used after the time such user is no longer the 

primary user of the primary computer on which the Software is installed.  

c. In the event the Software is distributed along with other PremiumSoft software products as part of a suite of 

products (collectively, the "Studio"), the license of the Studio is licensed as a single product and none of the 

products in the Studio, including the Software, may be separated for installation or use on more than one 

computer.  

d. You may make one copy of the Software in machine-readable form solely for backup purposes. You must 

reproduce on any such copy all copyright notices and any other proprietary legends on the original copy of the 

Software. You may not sell or transfer any copy of the Software made for backup purposes.  

e. You agree that PremiumSoft may audit your use of the Software for compliance with these terms at any time, 

upon reasonable notice. In the event that such audit reveals any use of the Software by you other than in full 

compliance with the terms of this Agreement, you shall reimburse PremiumSoft for all reasonable expenses 

related to such audit in addition to any other liabilities you may incur as a result of such non-compliance.  

f. Your license rights under this EULA are non-exclusive.  

3. License Restrictions 

a. Other than as set forth in Section 2, you may not make or distribute copies of the Software, or electronically 

transfer the Software from one computer to another or over a network.  

b. You may not alter, merge, modify, adapt or translate the Software, or decompile, reverse engineer, 

disassemble, or otherwise reduce the Software to a human-perceivable form.  

c. Unless otherwise provided herein, you may not rent, lease, or sublicense the Software.  

d. Other than with respect to a Trial / Demo Version, Non-commercial Lite Version or a Not For Resale Version of 

the Software, you may permanently transfer all of your rights under this EULA only as part of a sale or transfer, 

provided you retain no copies, you transfer all of the Software (including all component parts, the media and 

printed materials, any upgrades, this EULA, the serial numbers, and, if applicable, all other software products 

provided together with the Software), and the recipient agrees to the terms of this EULA. If the Software is an 

upgrade, any transfer must include all prior versions of the Software from which you are upgrading. If the copy 

of the Software is licensed as part of the whole Studio (as defined above), the Software shall be transferred 

only with and as part of the sale or transfer of the whole Studio, and not separately. You may retain no copies 

of the Software. You may not sell or transfer any Trial / Demo Version, Non-commercial Lite Version or Not For 

Resale Version of the Software.  

e. Unless otherwise provided herein, you may not modify the Software or create derivative works based upon the 

Software.  

f. Non-commercial Versions of the Software may not be used for, or distributed to any party for, any commercial 

purpose.  

g. Unless otherwise provided herein, you shall not  

A. in the aggregate, install or use more than one copy of the Trial / Demo Version and Non-commercial 

Lite Version of the Software,  

B. download the Trial / Demo Version and Non-commercial Lite Version of the Software under more than 

one username,  
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C. alter the contents of a hard drive or computer system to enable the use of the Trial / Demo Version of 

the Software for an aggregate period in excess of the trial period for one license to such Trial / Demo 

Version,  

D. disclose the results of software performance benchmarks obtained using the Trial / Demo Version or 

Non-commercial Lite Version to any third party without PremiumSoft prior written consent, or  

E. use the Trial / Demo Version of the Software for a purpose other than the sole purpose of determining 

whether to purchase a license to a commercial or education version of the software; provided, however, 

notwithstanding the foregoing, you are strictly prohibited from installing or using the Trial / Demo 

Version or Non-commercial Lite Version of the Software for any commercial training purpose.  

h. You may only use the Not for Resale Version of the Software to review and evaluate the Software.  

i. You may receive the Software in more than one medium but you shall only install or use one medium. 

Regardless of the number of media you receive, you may use only the medium that is appropriate for the 

server or computer on which the Software is to be installed.  

j. You may receive the Software in more than one platform but you shall only install or use one platform.  

k. You shall not use the Software to develop any application having the same primary function as the Software.  

l. In the event that you fail to comply with this EULA, PremiumSoft may terminate the license and you must 

destroy all copies of the Software (with all other rights of both parties and all other provisions of this EULA 

surviving any such termination).  

m. This program may include Oracle Instant Client (OCI). You agree that you shall  

1. not use of the Oracle Instant Client to the business operations;  

2. not assign, give, or transfer the Oracle Instant Client or an interest in them to another individual or 

entity;  

a. make the Programs available in any manner to any third party for use in the third party's 

business operations; and  

b. title to the Programs from passing to the end user or any other party;  

3. not reverse engineer, disassemble or decompilation the Oracle Instant Client and duplicate the 

Programs except for a sufficient number of copies of each Program for your licensed use and one copy 

of each Program media;  

4. discontinue use and destroy or return to all copies of the Oracle Instant Client and documentation after 

termination of the Agreement;  

5. not pubish any results of benchmark tests run on the Programs;  

6. comply fully with all relevant export laws and regulations of the United States and other applicable 

export and import laws to assure that neither the Oracle Instant Client, nor any direct product thereof, 

are exported, directly or indirectly, in violation of applicable laws;  

7. allow PremiumSoft to audit your use of the Oracle Instant Client;  

4. Upgrades 

If this copy of the Software is an upgrade from an earlier version of the Software, it is provided to you on a license 

exchange basis. You agree by your installation and use of such copy of the Software to voluntarily terminate your 

earlier EULA and that you will not continue to use the earlier version of the Software or transfer it to another person or 

entity unless such transfer is pursuant to Section 3.  
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5. Ownership 

The foregoing license gives you limited license to use the Software. PremiumSoft and its suppliers retain all rights, title 

and interest, including all copyright and intellectual property rights, in and to, the Software (as an independent work and 

as an underlying work serving as a basis for any application you may develop), and all copies thereof. All rights not 

specifically granted in this EULA, including Federal and International Copyrights, are reserved by PremiumSoft and its 

suppliers.  

6. LIMITED WARRANTY AND DISCLAIMER 

a. Except with respect to Trial / Demo Version, Non-commercial Lite Version and Not For Resale Version of the 

Software, PremiumSoft warrants that, for a period of thirty (30) days from the date of delivery (as evidenced by 

a copy of your receipt): the physical media on which the Software is furnished will be free from defects in 

materials and workmanship under normal use. The Software is provided "as is". PremiumSoft makes no 

warranties, express or implied, arising from course of dealing or usage of trade, or statutory, as to any matter 

whatsoever.  

b. PremiumSoft provides no remedies or warranties, whether express or implied, for Trial / Demo version, 

Non-commercial Lite version and the Not for Resale version of the Software. Trial / Demo version, 

Non-commercial Lite version and the Not for Resale version of the Software are provided "as is".  

c. Except as set Forth in the foregoing limited warranty with respect to software other than Trial/ Demo version, 

Non-commercial Lite version and Not for Resale version, PremiumSoft and its suppliers disclaim all other 

warranties and representations, whether express, implied, or otherwise, including the warranties of 

merchantability or fitness for a particular purpose. Also, there is no warranty of non-infringement and title or 

quiet enjoyment. PremiumSoft does not warrant that the Software is error-free or will operate without 

interruption. The Software is not designed, intended or licensed for use in hazardous environments requiring 

fail-safe controls, including without limitation, the design, construction, maintenance or operation of nuclear 

facilities, aircraft navigation or communication systems, air traffic control, and life support or weapons systems. 

PremiumSoft specifically disclaims any express or implied warranty of fitness for such purposes.  

d. If applicable law requires any warranties with respect to the Software, all such warranties are limited in duration 

to thirty (30) days from the date of delivery.  

e. No oral or written information or advice given by PremiumSoft, its dealers, distributors, agents or employees 

shall create a warranty or in any way increase the scope of ANY warranty PROVIDED HEREIN.  

7. LIMITATION OF LIABILITY 

(a) Neither PremiumSoft nor its suppliers shall be liable to you or any third party for any indirect, special, incidental, 

punitive or consequential damages (including, but not limited to, damages for the inability to use equipment or access 

data, loss of business, loss of profits, business interruption or the like), arising out of the use of, or inability to use, the 

Software and based on any theory of liability including breach of contract, breach of warranty, 

tort (including negligence), product liability or otherwise, even if PremiumSoft or its representatives have been advised 

of the possibility of such damages.  

8. Third Party Software 
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The Software may contain third party software which requires notices and/or additional terms and conditions. By 

accepting this EULA, you are also accepting the additional terms and conditions of the third party software.  

9. General 

No PremiumSoft dealer, agent or employee is authorized to make any amendment to this EULA.  

This EULA contains the complete agreement between the parties with respect to the subject matter hereof, and 

supersedes all prior or contemporaneous agreements or understandings, whether oral or written. You agree that any 

varying or additional terms contained in any purchase order or other written notification or document issued by you in 

relation to the Software licensed hereunder shall be of no effect. The failure or delay of PremiumSoft to exercise any of 

its rights under this EULA or upon any breach of this EULA shall not be deemed a waiver of those rights or of the 

breach. 

If any provision of this EULA shall be held by a court of competent jurisdiction to be contrary to law, that provision will 

be enforced to the maximum extent permissible, and the remaining provisions of this EULA will remain in full force and 

effect.  

10. Basis of Bargain 

The Limited Warranty and Disclaimer and Limited Liability set forth above are fundamental elements of the basis of the 

agreement between PremiumSoft and you. PremiumSoft would not be able to provide the Software on an economic 

basis without such limitations. Such Limited Warranty and Disclaimer and Limited Liability inure to the benefit of 

PremiumSoft's licensors.  

11. Term 

By downloading and/or installing this SOFTWARE, the Licensor agrees to the terms of this EULA. 

This license is effective until terminated. Licensor has the right to terminate your License immediately if you fail to 

comply with any term of this License.  

"as is". Licensor makes no warranties, express or implied, arising from course of dealing or usage of trade, or statutory, 

as to any matter whatsoever. In particular, any and all warranties or merchantability, fitness for a particular purpose or 

non-infringement of third party rights are expressly excluded. 

12. Governing Law 

This License will be governed by the laws in force in Hong Kong. You hereby consent to the non-exclusive jurisdiction 

and venue sitting in Hong Kong to resolve any disputes arising under this EULA. 

Should you have any questions concerning the validity of this License, please contact: licensing@navicat.com. If you 

desire to contact the Licensor for any other reason, please contact support@navicat.com. 

PremiumSoft and other trademarks contained in the Software are trademarks or registered trademarks of PremiumSoft 

CyberTech Ltd. in the United States and/or other countries. Third party trademarks, trade names, product names and 
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logos may be the trademarks or registered trademarks of their respective owners. You may not remove or alter any 

trademark, trade names, product names, logo, copyright or other proprietary notices, legends, symbols or labels in the 

Software. This EULA does not authorize you to use PremiumSoft or its licensors names or any of their respective 

trademarks.  
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Chapter 2 - User Interface 

Main Window 

The Main Window consists of several toolbars and panes for you to work on connections, database objects and 

advanced tools. 

 

 Main Toolbar 

The Main Toolbar allows you to access basic objects and features, such as connections, users, tables, backup, 

automation and more. To use small icons or hide the captions, right-click on the toolbar and disable Use Big Icons or 

Show Caption. 

 Navigation Pane 

The Navigation Pane is the basic way to navigate with connections, databases and database objects. If the Navigation 

Pane is hidden, choose View -> Navigation Pane -> Show Navigation Pane from the menu bar. 

 Tab Bar 

The Tab Bar allows you to switch among the tabbed windows on the Object Pane. You can choose to always display 

pop-ups on a new tab, or to always display them in a new window. If you have multiple tabs open, you can use 

CTRL+TAB to easily switch to other tabs. See also Options. 

 Object Toolbar 

The Object Toolbar provides other controls that you can use to manipulate the objects. 

 Object Pane 
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The Object Pane displays a list of object such as tables, views, queries, and the tabbed window forms. Use the  

List,  Detail and  ER Diagram buttons to change the view of the Objects tab. 

 Information Pane 

The Information Pane shows the detailed object information, project activities, the DDL of database objects, object 

dependencies, membership of users/roles and preview. If the Information Pane is hidden, choose View -> Information 

Pane -> Show Information Pane from the menu bar. 

 Status Bar 

The Status Bar displays the current window's status information. 

Navigation Pane 

The Navigation pane employs tree structure which allows you to take action upon the database and their objects 

through their pop-up menus quickly and easily. If the Show objects in Navigation Pane option is checked at the 

Options window, all database objects are also displayed in the pane. To connect to a database or schema, simply 

double-click it in the pane. 

After logged in the Navicat Cloud feature, the Navigation pane will be divided into Navicat Cloud and My Connections 

sections. 

 

You can filter the tree by focusing the tree and type the searching string. To show the opened objects only, choose 

View -> Navigation Pane -> Show Only Active Objects from the menu bar. 

If you want to hide the group structure in the Navigation pane, select View -> Navigation Pane -> Flatten Connection. 

If the Navigation pane is hidden, choose View -> Navigation Pane -> Show Navigation Pane. 
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Object Pane 

In the Objects tab, you can use the  List,  Detail and  ER Diagram buttons to change the object view. 

If you want to hide the group structure in List view or Details view, select View -> Flatten Object List from the menu 

bar. 

List View 

By default, Navicat uses the List view. It only shows the names of objects. 

Detail View 

Detail view shows the name and several properties of objects in columns. To change the display columns of properties, 

select View -> Choose Columns from the menu bar and select display columns for different objects from the pop-up 

window. 

ER Diagram View (Available only in Non-Essentials Edition) 

Note: Only tables provide ER Diagram view. 

An ER diagram will be generated automatically if the selected database/schema contains tables. ER diagram files are 

stored under Settings Location. 

 

 Diagram Canvas 

Display table fields and relationships between tables in a database/schema graphically. You can add, edit or delete 

relations between tables, and also add or delete vertices on a relation line. 

Add a Foreign Key 

Click  from the object toolbar. Drag and drop a field from the child table to the parent table. 
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Edit or Delete a Foreign Key 

Right-click a relation line and select Design Foreign Key or Delete Foreign Key from the pop-up menu. 

Add or Delete a Vertex 

Select a relation line or a vertex. Press and hold the SHIFT key and click on the relation line or the vertex. 

Note: Double-click a table in the ER Diagram view will open the Table Designer, while double-click a table in the List or 

Detail view will open the Table Viewer. 

 Overview 

To zoom in or zoom out the selected area of the diagram, adjust the slider of the Overview. Same effect can be 

achieved with keyboard shortcuts: 

Zoom In: [CTRL++] or [CTRL+Mousewheel up] 

Zoom Out: [CTRL+-] or [CTRL+Mousewheel down] 

 Bottom Toolbar 

 Refresh 

Refresh the ER diagram. Choose Regenerate ER Diagram to regenerate the ER diagram with using auto layout 

feature. 

 Move Diagram 

Switch to hand mode for moving the diagram. Or, you can press and hold the SPACE key, then move the diagram. 

 New Relation 

Add a relation between two table fields. Click this button, and then drag and drop a field from the child table to the 

parent table. 

 Color 

Set the color of the selected tables or relations. 

Paper Size 

Select a paper size from the drop-down list. The corresponding paper size will reflect in the Overview. 

Information Pane 

The Information Pane shows the detailed object information, project activities, the DDL of database objects, object 

dependencies, membership of users/roles and preview. If the Information Pane is hidden, choose View -> Information 

Pane -> Show Information Pane from the menu bar. 
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You can select any connections, objects or projects, and then select the corresponding buttons on the Information 

Pane. 

Button Description 

 

General - Show the general information of the object/project. 

 

Preview - Show the SQL statements in the query. 

 

DDL - Show the DDL statements of the object. 

 

Using - Show the objects that the selected object depends on. 

Objects - Show the objects in the tablespace. 

Member Of - Show the roles that the user or the role assigned to. 

 

Used By - Show the objects that depend on the selected object.  

Members - Show the members of the role. 

 

Code Snippet - Show all built-in and custom code snippets. 

(Available only in Non-Essentials Edition) 

 

Identifiers - Show all tables, views and columns in the selected database or schema. 

 

Project - Show the project members and the project activities done by the members. 

Click + to add members to the project. 
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Chapter 3 - Navicat Cloud 

About Navicat Cloud 

Navicat Cloud provides a cloud service for synchronizing connections, queries, model files and virtual group 

information from Navicat, other Navicat family members, different machines and different platforms. All the Navicat 

Cloud objects are located under different projects. You can share the project to other Navicat Cloud accounts for 

collaboration. 

Create a new account 

1. In the main window, click Sign In and click Create Navicat ID. 

2. Enter the required information and click the Sign Up button. A verification email will send to your email 

address. 

3. Click the link in the email to verify the new account. 

Hint: You can sign in with the same Navicat ID you use for the Navicat Customer Center. 

Sign in Navicat Cloud 

1. In the main window, click Sign In and enter your Navicat ID and Password. 

2. Click the Sign In button. 

3. If you enabled two-step verification in Navicat Cloud Portal site, a code will be sent to your phone via your 

mobile app. Enter the received code to sign in. 

Sign out Navicat Cloud 

1. In the main window, right-click Navicat Cloud and choose Close All Connections to close all connections 

under Navicat Cloud. 

2. Click your avatar on the toolbar. 

3. Click your email in the Navicat Cloud window and choose Sign Out. 

Manage Navicat Cloud 

View the cloud usage 

1. In the main window, click your avatar on the toolbar. 

2. Your cloud usage and current plan will be shown in the Navicat Cloud window. 

Note: A connection, a query, a model or a virtual group counts for one unit. 

https://cloud.navicat.com/
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Change your avatar 

1. In the main window, click your avatar on the toolbar. 

2. Click the avatar in the Navicat Cloud window. 

3. Choose an image file. 

Manage your Navicat Cloud account 

1. In the main window, click your avatar on the toolbar. 

2. Click your email in the Navicat Cloud window and choose Manage Account. 

3. A browser will open with Navicat Cloud Portal site. 

Upgrade the Navicat Cloud plan 

1. In the main window, click your avatar on the toolbar. 

2. Click Upgrade in the Navicat Cloud window. 

3. A browser will open with Navicat Cloud Portal site. 

Create a project 

1. Select Navicat Cloud in the Navigation pane. 

2. Right-click it and choose New Project. 

Add members to a project 

1. Select a project in the Navigation pane. 

2. Right-click it and choose Collaborate with. 

3. Click Add Members. 

4. Enter the members' Navicat ID. 

5. Select the member role. 

6. Click Add. 

Member Roles  Privileges 

Owner Read Objects, Write Objects, Manage Members and Delete Project 

Admin Read Objects, Write Objects and Manage Members 

Member Read Objects and Write Objects 

Guest Read Objects 

https://cloud.navicat.com/
https://cloud.navicat.com/
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Note: Each time can add up to 10 members. Use comma or enter to separate the members in the edit box. 

Manage members in a project 

1. Select a project in the Navigation pane. 

2. Right-click it and choose Collaborate with. 

3. Click Apply after changes. 

Note: If you are the Owner or Admin, you can click the x button to remove the member. 

Rename a project 

1. Select a project in the Navigation pane. 

2. Right-click it and choose Rename. 

3. Enter the project name. 

Quit a project 

1. Select a project in the Navigation pane. 

2. Right-click it and choose Quit Project. 

Delete a project 

1. Select a project in the Navigation pane. 

2. Right-click it and choose Delete Project. 

Move/copy a connection to a project 

1. Right-click a connection under My Connections and choose Move Connection to or Copy Connection to. 

2. Select an existing project or create a new project. 

3. The connection will move or copy to Navicat Cloud. And, all its query files and virtual groups will store in 

Navicat Cloud. 

Move/copy a connection to My Connections 

1. Right-click a connection under Navicat Cloud and choose Move Connection to or Copy Connection to -> 

My Connections. 

2. The connection will move or copy to My Connections. And, all its query files and virtual groups will store in the 

local machine. 

Move/copy a model to Navicat Cloud 
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1. Select a model file under My Connections. 

2. Drag and drop it to a project in Navicat Cloud. 

Move/copy a model to My Connections 

1. Select a model file in a project under Navicat Cloud. 

2. Drag and drop it to My Connections. 

  



 24 

 

Chapter 4 - Connection 

About Connection 

To start working with your server in Navicat, you should first establish a connection or several connections using the 

Connection window. If you are new to the server or 'Net in general' and are not quite sure how things work, you may 

want to look at: 

· MySQL User Manual 

· Oracle Database Documentation 

· PostgreSQL User Manual 

· SQLite User Manual 

· MariaDB Documentation 

To create a new connection, click  Connection and select your server type. Then, enter the necessary information 

in the Connection window. 

Note: Navicat authorizes you to make connection to remote servers running on different platforms (i.e. Windows, Mac, 

Linux and UNIX), and supports PAM and GSSAPI authentication. 

You can edit the connection properties by right-click the connection and choose Edit Connection. 

Navicat Cloud 

To copy or move a connection between My Connections and Navicat Cloud, right-click the connection and choose 

Copy Connection to or Move Connection to. 

Flush MySQL/MariaDB Connection 

To clear or reload various internal caches, flush tables, or acquire locks, right-click your connection in the Navigation 

pane and select Flush and choose the flush option. You must have the RELOAD privilege to use this feature. 

Testing Account 

Navicat provides evaluated accounts for testing purpose. 

MySQL 

· Host Name/IP Address: server1.navicat.com 

· Port: 4406 

· User Name: navicat 

http://dev.mysql.com/doc/
http://www.oracle.com/technology/documentation/index.html
http://www.postgresql.org/docs/manuals/
http://www.sqlite.org/docs.html
https://mariadb.com/kb/en/mariadb-documentation/
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· Password: testnavicat 

PostgreSQL 

· Host Name/IP Address: server1.navicat.com 

· Port: 5432 

· Initial Database: HR 

· User Name: navicat 

· Password: testnavicat 

General Settings 

To successfully establish a new connection to local/remote server - no matter via SSL, SSH or HTTP, set the database 

login information in the General tab. If your Internet Service Provider (ISP) does not provide direct access to its server, 

Secure Tunneling Protocol (SSH) / HTTP is another solution. 

Note: The following options depend on the connection server type and sort in ascending order. 

Add To 

After you logged in the Navicat Cloud feature, you can choose to save the connection to My Connections or a project in 

Navicat Cloud. 

Connection Name 

Enter a friendly name to best describe your connection. 

Connection Type 

Basic In Basic mode, it connects to Oracle through the Oracle Call Interface (OCI). Enter 

the Host Name/IP Address and Port. Set the Service Name/SID which the user 

connects when making connection. Select the corresponding radio button. 

OCI is an application programming interface that allows an application developer to use a third-generation language's 

native procedure or function calls to access the Oracle database server and control all phases of SQL statement 

execution. OCI is a library of standard database access and retrieval functions in the form of a dynamic-link library. See 

also: OCI options 

Database File 

Specify the initial database file. If the HTTP Tunnel is enabled, you need to enter an absolute file path of the database 

file in your web server. 

Endpoint 



 26 

 

The Endpoint for connecting to the Amazon Web Services instance. 

Host Name/IP Address 

A host name where the database is situated or the IP address of the server. 

Initial Database 

Set the initial database which user connects when making connection. 

Password 

Password for connecting to the database server. 

Port 

A TCP/IP port for connecting to the database server. 

Sync User Name with Navicat Cloud 

When editing a connection in Navicat Cloud, you can choose to synchronize the user name. 

Type 

Existing Database File Connect to an existing database in the Database File. 

New SQLite 3 Create a new SQLite 3 database in the Database File. 

New SQLite 2 Create a new SQLite 2 database in the Database File. 

User Name 

User name for connecting to the database server. 

SSL Settings 

Secure Sockets Layer(SSL) is a protocol for transmitting private documents via the Internet. To get a secure 

connection, the first thing you need to do is to install OpenSSL Library and download Database Source. 

Note: Available only for MySQL, PostgreSQL and MariaDB. Support from PostgreSQL 8.4 or later. 

MySQL and MariaDB Connections 

To provide authentication details, enable Use Authentication and fill in the required information: 

Client Key 

The SSL key file in PEM format to use for establishing a secure connection. 

Client Certificate 

The SSL certificate file in PEM format to use for establishing a secure connection. 



 27 

 

CA Certificate 

The path to a file in PEM format that contains a list of trusted SSL certificate authorities. 

Verify CA Certificate Name 

Check the server's Common Name value in the certificate that the server sends to the client. 

Specified Cipher 

A list of permissible ciphers to use for SSL encryption. 

PostgreSQL Connection 

Choose the SSL Mode: 

allow First try a non-SSL connection; if that fails, try an SSL connection. 

prefer First try an SSL connection; if that fails, try a non-SSL connection. 

require Only try an SSL connection. 

verify-ca Only try an SSL connection, and verify that the server certificate is issued by a 

trusted CA. 

verify-full Only try an SSL connection, verify that the server certificate is issued by a trusted 

CA and that the server hostname matches that in the certificate. 

To provide authentication details, enable Use Authentication and fill in the required information: 

Client Key 

The path of the client private key. 

Client Certificate 

The path of the client certificate. 

CA Certificate 

The path of the trusted certificate authorities. 

Certificate Revocation List 

The file path of the SSL certificate revocation list (CRL). 

SSH Settings 

Secure SHell (SSH) is a program to log in into another computer over a network, execute commands on a remote 

server, and move files from one machine to another. It provides strong authentication and secure encrypted 

communications between two hosts, known as SSH Port Forwarding (Tunneling), over an insecure network. 

Typically, it is employed as an encrypted version of Telnet. 
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In a Telnet session, all communications, including username and password, are transmitted in plain-text, allowing 

anyone to listen-in on your session and steal passwords and other information. Such sessions are also susceptible to 

session hijacking, where a malicious user takes over your session once you have authenticated. SSH serves to prevent 

such vulnerabilities and allows you to access a remote server's shell without compromising security. 

Note: Available only for MySQL, Oracle, PostgreSQL and MariaDB. 

Please make sure that the parameter - "AllowTcpForwarding" in the Linux server must be set to value "yes", otherwise, 

the SSH port forwarding will be disabled. To look for the path: /etc/ssh/sshd_config. By default, the SSH port forwarding 

should be enabled. Please double check the value settings. 

Even the server support SSH tunnel, however, if the port forwarding being disabled, Navicat cannot connect via SSH 

Port 22. 

Host Name/IP Address 

A host where SSH server is activated. 

Note: The host name in the General tab should be set relatively to the SSH server which provided by your database 

hosting company. 

Port 

A port where SSH server is activated, by default it is 22. 

User Name 

A user on SSH server machine. (It is not a user of database server.) 

Authentication Method 

Password Provide the SSH server user Password. 

Public Key Private Key 

It is used together with your public key. The private key should be readable only by 

you. 

Passphrase 

A passphrase is exactly like a password, except that it applies to the keys you are 

generating and not an account. 

Note: HTTP Tunnel and SSH Tunnel cannot be function simultaneously. The SSH Tunnel is disabled when you select 

the HTTP Tunnel and vice versa. 

HTTP Settings 

HTTP Tunneling is a method for connecting to a server that uses the same protocol (http://) and the same port (port 80) 

as a web server does. It is used while your ISPs do not allow direct connections, but allows establishing HTTP 

connections. 
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Note: Available only for MySQL, PostgreSQL, SQLite and MariaDB. 

Uploading the Tunneling Script 

To use this connection method, first thing you need to do is to upload the tunneling script to the web server where your 

server is located. 

Note: ntunnel_mysql.php (for both MySQL and MariaDB), ntunnel_pgsql.php or ntunnel_sqlite.php is available in 

the Navicat installation folder. 

Setting up HTTP Tunnel 

The following instruction guides you through the process of configuring a HTTP connection. 

1. Select the HTTP tab and enable Use HTTP Tunnel. 

2. Enter URL of the tunneling script. 

e.g. http://www.navicat.com/ntunnel_mysql.php 

3. If your server installed a Web Application Firewall, you can check the Encode outgoing query with base64 

option. 

4. If the tunneling script is hosted in a password protected server or you have to access internet over a proxy 

server, you can provide the required authentication details in the Authentication or Proxy tab. 

Note: HTTP Tunnel and SSH Tunnel cannot be function simultaneously. The SSH Tunnel is disabled when you select 

the HTTP Tunnel and vice versa. 

Advanced Settings 

Note: The following options depend on the connection server type and sort in ascending order. 

Auto Connect 

Open the connection at application startup automatically. 

Encoding 

Choose a codepage to communicate with MySQL Server while MySQL character set not being employed. 

Encrypted 

Enable this option and provide Password when connecting to an encrypted SQLite database. 

Keepalive Interval (sec) 

Keep the connection with the server alive by pinging it. You can set the period between pings in the edit box. 

Max no. of session 
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Specify the maximum number of concurrent connections that the server allows. 

OS Authentication 

Use Windows user login credentials to authenticate database users. 

Role 

Indicate that the database user is connecting with either the Default, SYSOPER or SYSDBA system privilege. 

Settings Location 

When a new connection is being established, Navicat will create a subfolder under the Settings Location. Most files are 

stored within this subfolder: 

File in Settings Location Server Type File Extension 

Backup MySQL, PostgreSQL, SQLite and 

MariaDB 

.nb3 

Backup Profile MySQL .nbakmysql 

PostgreSQL .nbakpgsql 

SQLite .nbaksqlite 

MariaDB .nbakmysql 

Data Pump Export Profile Oracle .nbakora 

ER Diagram File All .ned 

Export Materialized View 

Profile 

Oracle .nexpmora 

PostgreSQL .nexpmpgsql 

Export Query Result Profile MySQL .nexpqmysql 

Oracle .nexpqora 

PostgreSQL .nexpqpgsql 

SQLite .nexpqsqlite 

MariaDB .nexpqmariadb 

Export Table Profile MySQL .nexptmysql 

Oracle .nexptora 

PostgreSQL .nexptpgsql 

SQLite .nexptsqlite 

MariaDB .nexptmariadb 

Export View Result Profile MySQL .nexpvmysql 

Oracle .nexpvora 

PostgreSQL .nexpvpgsql 

SQLite .nexpvsqlite 

MariaDB .nexpvmariadb 

Import Table Profile MySQL .nimpmysql 

Oracle .nimpora 

PostgreSQL .nimppgsql 
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SQLite .nimpsqlite 

MariaDB .nimpmariadb 

Query All .sql 

Use Compression 

Use compression protocol. It is used if both client and server support zlib compression, and the client requests 

compression. 

Use Named Pipe, Socket 

Use socket file for localhost connection. 

Databases / Attached Databases Settings 

MySQL, Oracle, PostgreSQL, MariaDB 

In the Databases tab, you can set which databases will be shown in the Navigation pane when connecting to your 

server. It is not obligatory. To start working with custom database settings, check Use Custom Database List. Then, 

select the preferable databases in the Database column. If you want Navicat automatically open the databases at 

connection, check the Auto Connect box. 

Add a hidden database to the list 

1. Click the Add DB to List button. 

2. Enter the database name. 

3. Select the newly added database in the database list. 

Remove a database from the list 

1. Select the database in the database list. 

2. Click the Remove DB from List button. 

Note: The database will be just removed from the database list box, it will still exist in the server. 

SQLite 

In the Attached Databases tab, you can attach SQLite database files to the connection. Click the Attach Database 

button and enter the information: 

Option Description 

Database File Choose the file path of a database file. 

Database Name Enter the database name which displays in Navicat. 

Encrypted Check this option and provide the Password if the database file is encrypted. 

To detach a database, select it from the list and click the Detach Database button. 
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Chapter 5 - Server Objects 

About Server Objects 

Navicat provides powerful tools to manage server objects, such as databases, tables, views, functions, etc. 

Note: Before working with the server objects in Navicat, you should establish the connection first. 

In object designers, you can preview the CREATE statement and the necessary SQL statements for creating/editing 

the object in the SQL Preview tab. For some database or schema objects, you can use the bottom drop-down list to 

show the SQL which will be run when choosing Save or Save As from the File menu. 

MySQL / MariaDB 

Databases 

To start working with the server objects, you should create and open a connection. If the server is empty, you need to 

create a new database. 

Create a new database 

1. In the Navigation pane, right-click your connection and choose New Database. 

2. Enter the database properties in the pop-up window. 

Edit an existing database 

1. In the Navigation pane, right-click a database and choose Edit Database. 

2. Edit the database properties in the pop-up window. 

Note: MySQL does not support renaming database through its interface at this moment. Access the directory in which 

databases being stored. By default, all databases store within a directory called data under MySQL Installation folder. 

For example: /var/lib/mysql/. You must stop MySQL before you can rename the database. 

Tables 

Tables are database objects that contain all data in a database. A table is a set of rows and columns, and their 

intersections are fields. In the main window, click  Table to open the table object list. 

There are two ways to open a table with graphical fields, right-click a table and choose: 

Option Description 

Open Table Navicat loads all your BLOB fields (images) while opening the table. 

Open Table (Quick) Faster performance for opening the graphical table, as BLOB fields (images) will 

not be loaded until you click on the cell. (It is invisible by default until you hold 

down the SHIFT key when right-clicking the table.) 
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To empty a table, right-click the selected table and choose Empty Table from the pop-up menu. This option is only 

applied when you wish to clear all the existing records without resetting the auto-increment value. To reset the 

auto-increment value while emptying your table, use Truncate Table. 

Table Designer 

Table Designer is the basic Navicat tool for working with tables. It allows you to create, edit and drop table's fields, 

indexes, foreign keys, and much more. 

In the Fields tab, you can search a field name by choosing Edit -> Find or pressing CTRL+F. 

Note: The tabs and options in the designer depend on the server type and version. 

Table Viewer 

When you open a table, Table Viewer displays data as a grid. Data can be displayed in two modes: Grid View and 

Form View. See Data Viewer for details. 

Note: Transaction is only available for INNODB tables. 

Views 

A view allows users to access a set of tables as if it is a single table. You can use views to restrict access to rows. In the 

main window, click  View to open the view object list. 

View Designer 

View Designer is the basic Navicat tool for working with views. You can edit the view definition as SQL statement 

(SELECT statement it implements) in the Definition tab. To customize the view of the editor and find out more features 

for SQL editing, see SQL Editor for details. If you want to load SQL statement from a SQL file to the editor, you can 

choose File -> Import SQL. 

Button Description 

 Preview Preview the data of the view. 

 Explain Show the Query Plan of the view. 

 View Builder Build the view visually. It allows you to create and edit views without knowledge 

of SQL. See SQL Builder for details. 

 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 

Hint: You can choose to show the preview results below the editor or in a new tab by selecting View -> Show Result 

-> Below Query Editor or In a New Tab. 

View Viewer 

When you open a view, View Viewer displays data as a grid. Data can be displayed in two modes: Grid View and Form 

View. See Data Viewer for details. 

Note: Transaction is only available for updatable views. 
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Procedures / Functions 

Procedures and functions (stored routines) are supported in MySQL 5.0. A stored routine is a set of SQL statements 

that can be stored in the server. In the main window, click  Function to open the function object list. 

Function Wizard 

Click  New Function from the object toolbar. Function Wizard will pop up and it allows you to create a 

procedure/function easily. 

1. Select the type of the routine: Procedure or Function. 

2. Define the parameters. Set the Mode, Name and/or Type under the corresponding columns. 

3. If you create a function, select the Return Type from the list and enter the corresponding information: Length, 

Decimals, Character set and/or Enum. 

Hint: Once uncheck the Show wizard next time option, you can go to Options to enable it. 

Function Designer 

Function Designer is the basic Navicat tool for working with procedures/functions. You can enter a valid SQL 

statement in the Definition tab. This can be a simple statement such as SELECT or INSERT, or it can be a compound 

statement written using BEGIN and END. Compound statements can contain declarations, loops, and other control 

structure statements. To customize the view of the editor and find out more features for SQL editing, see SQL Editor for 

details. 

Results 

To execute the procedure/function, click  Execute on the toolbar. If the SQL statement is correct, the statement will 

be executed and, if the statement is supposed to return data, the Result tab opens with the data returned. If an error 

occurs while executing the procedure/function, execution stops, the appropriate error message is displayed. If the 

procedure/function requires input parameters, the Input Parameter dialog will pop up. 

Note: Navicat supports to return 10 result sets. 

Events 

An event is a task that run according to a schedule. In the main window, click  Event to open the event object list. 

Event Designer 

Event Designer is the basic Navicat tool for working with events. You can enter a valid SQL procedure statement in 

the Definition tab. This can be a simple statement such as SELECT or INSERT, or it can be a compound statement 

written using BEGIN and END. Compound statements can contain declarations, loops, and other control structure 

statements. To customize the view of the editor and find out more features for SQL editing, see SQL Editor for details. 
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Maintain Objects 

Navicat provides a complete solution for maintaining MySQL / MariaDB objects. 

1. In the main window, select objects in the Navigation pane or the Objects tab. 

2. Right-click the selected objects. 

3. Choose Maintain, and then choose a maintain option the from the pop-up menu. 

4. Results show in a pop-up window. 

Table 

Option Description 

Analyze Tables Analyze and store the key distribution for the table. 

Check Tables Check the table for errors. 

Optimize Tables Optimize the table to reduce storage space and improve I/O efficiency. 

Repair Tables Repair the possibly corrupted table. 

Get Rows Count Count the number of rows in the table. 

 

Oracle 

Schemas 

To start working with the server objects, you should create and open a connection. When you create a user account, 

you are also implicitly creating a schema for that user. A schema is a logical container for the database objects (such 

as tables, views, triggers, and so on) that the user creates. The schema name is the same as the user name, and can 

be used to unambiguously refer to objects owned by the user. 

Hint: Oracle interprets non-quoted object identifiers as uppercase. In Navicat, all object identifiers will be quoted. That 

is, Navicat saves exactly what you have inputted. 

Tables 

Tables are database objects that contain all data in a database. A table is a set of rows and columns, and their 

intersections are fields. In the main window, click  Table to open the table object list. 

You can create Normal / External / Index Organized tables. Click the down arrow next to  New Table from the 

object toolbar and choose the table type. 

There are two ways to open a table with graphical fields, right-click a table and choose: 

Option Description 

Open Table Navicat loads all your BLOB fields (images) while opening the table. 

Open Table (Quick) Faster performance for opening the graphical table, as BLOB fields (images) will 

not be loaded until you click on the cell. (It is invisible by default until you hold 
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down the SHIFT key when right-clicking the table.) 

To empty a table, right-click the selected table and choose Empty Table from the pop-up menu. This option is only 

applied when you wish to clear all the existing records without resetting the auto-increment value. To reset the 

auto-increment value while emptying your table, use Truncate Table. 

Table Designer 

Table Designer is the basic Navicat tool for working with tables. It allows you to create, edit and drop table's fields, 

indexes, foreign keys, and much more. 

In the Fields tab, you can search a field name by choosing Edit -> Find or pressing CTRL+F. When creating a new 

table, you are allowed to insert fields or rearrange the order of the fields. 

Note: The tabs and options in the designer depend on the server version and the table type. 

Table Viewer 

When you open a table, Table Viewer displays data as a grid. Data can be displayed in two modes: Grid View and 

Form View. See Data Viewer for details. 

Views 

A view allows users to access a set of tables as if it is a single table. You can use views to restrict access to rows. In the 

main window, click  View to open the view object list. 

View Designer 

View Designer is the basic Navicat tool for working with views. You can edit the view definition as SQL statement 

(SELECT statement it implements) in the Definition tab. To customize the view of the editor and find out more features 

for SQL editing, see SQL Editor for details. If you want to load SQL statement from a SQL file to the editor, you can 

choose File -> Import SQL. 

Button Description 

 Preview Preview the data of the view. 

 Explain Show the Query Plan of the view. 

 View Builder Build the view visually. It allows you to create and edit views without knowledge 

of SQL. See SQL Builder for details. 

 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 

Hint: You can choose to show the preview results below the editor or in a new tab by selecting View -> Show Result 

-> Below Query Editor or In a New Tab. 

View Viewer 

When you open a view, View Viewer displays data as a grid. Data can be displayed in two modes: Grid View and Form 

View. See Data Viewer for details. 

http://192.168.1.247/online_manual/en/navicat/win_manual/#/data_viewer
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Materialized Views 

Materialized Views are schema objects that used to summarize, compute, replicate, and distribute data. In the main 

window, click  Materialized View to open the materialized view object list. 

To refresh a materialized view, right-click it in the Objects tab and select Refresh Materialized View from the pop-up 

menu. 

Materialized View Designer 

Materialized View Designer is the basic Navicat tool for working with materialized views. You can edit the view 

definition as SQL statement (SELECT statement it implements) in the Definition tab. To customize the view of the 

editor and find out more features for SQL editing, see SQL Editor for details. If you want to load SQL statement from a 

SQL file to the editor, you can choose File -> Import SQL. 

Button Description 

 Preview Preview the data of the materialized view. 

 Explain Show the Query Plan of the materialized view. 

 View Builder Build the materialized view visually. It allows you to create and edit materialized 

views without knowledge of SQL. See SQL Builder for details. 

 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 

Hint: You can choose to show the preview results below the editor or in a new tab by selecting View -> Show Result 

-> Below Query Editor or In a New Tab. 

Materialized View Viewer 

When you open a materialized view, Materialized View Viewer displays data as a grid. Data can be displayed in two 

modes: Grid View and Form View. See Data Viewer for details. 

Procedures / Functions 

Procedures and functions are schema objects that consist a set of SQL statements and stored in the server. In the 

main window, click  Function to open the function object list. 

Function Wizard 

Click  New Function from the object toolbar. Function Wizard will pop up and it allows you to create a 

procedure/function easily. 

1. Specify the Name of the routine and select the type of the routine: Procedure or Function. 

2. Define the parameters. Set the Name, Type, Mode and Default Value under the corresponding columns. 

3. If you create a function, select the Return Type from the list. 

Hint: Once uncheck the Show wizard next time option, you can go to Options to enable it. 
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Function Designer 

Function Designer is the basic Navicat tool for working with procedures/functions. You can enter a valid SQL 

statement in the Definition tab. To customize the view of the editor and find out more features for SQL editing, see 

SQL Editor for details. 

The Code Outline pane displays information about the procedure/function including parameters, code body, etc. If the 

Code Outline pane is hidden, choose View -> Code Outline. 

Note: Available only in Non-Essentials Edition. 

Button Description 

 

Refresh the code outline. 

 

Show the detail view of the code outline. 

 

Turn mouse over highlight on or off. 

 

Expand the selected item. 

 

Collapse the selected item. 

 

Toggle sorting by position. 

Results 

To execute the procedure/function, click  Execute on the toolbar. If the SQL statement is correct, the statement will 

be executed and, if the statement is supposed to return data, the DBMS Output tab opens with the data returned. If an 

error occurs while executing the procedure/function, execution stops, the appropriate error message is displayed. If the 

procedure/function requires input parameters, the Input Parameter dialog will pop up. 

Note: Navicat supports to return 10 result sets. 

Debug (Available only in Non-Essentials Edition) 

You can add/remove breakpoints for debugging by clicking  in the grey area beside each statement. 

Before debugging, click  Save As Debug to save and compile the procedure/function. Then, click  Debug on 

the toolbar to launch the Oracle Debugger. Enter the input parameters if necessary. 

Packages 

Packages are encapsulated collections of related procedures, stored functions, and other program objects stored 

together in the database. An package consists of two parts: a specification and a body. In the main window, click  

Others -> Package to open the package object list. 

Package Designer & Package Body Designer 

Package Designer and Package Body Designer are the basic Navicat tools for working with packages. After saving 

the package in Package Designer, you can edit its package body by clicking  New Package Body or  Design 

Package Body. 
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Likewise, you can edit its package specification by clicking  Design Package Specification in Package Body 

Designer. 

You can enter a valid SQL statement in the Definition tab. To customize the view of the editor and find out more 

features for SQL editing, see SQL Editor for details. 

The Code Outline pane displays information about the package/package body including function, procedure, 

parameter, code body, etc. If the Code Outline pane is hidden, choose View -> Code Outline. 

Note: Available only in Non-Essentials Edition. 

Button Description 

 

Refresh the code outline. 

 

Show the detail view of the code outline. 

 

Turn mouse over highlight on or off. 

 

Expand the selected item. 

 

Collapse the selected item. 

 

Toggle sorting by position. 

Results 

To execute the package, click  Execute on the toolbar. If the SQL statement is correct, the statement will be 

executed and, if the statement is supposed to return data, the DBMS Output tab opens with the data returned. If an 

error occurs while executing the package, execution stops, the appropriate error message is displayed. If the package 

requires input parameters, the Input Parameter dialog will pop up. 

Debug (Available only in Non-Essentials Edition) 

You can add/remove breakpoints for debugging by clicking  in the grey area beside each statement. 

Before debugging, click  Save As Debug to save and compile the package. Then, click  Debug on the toolbar 

to launch the Oracle Debugger. Enter the input parameters if necessary. 

Recycle Bin 

Recycle bin contains dropped tables and any associated objects such as indexes, constraints, nested tables. In the 

main window, click  Others -> Recycle Bin to open the recycle bin object list. 

Restore a table 

1. Select a table in the Objects tab. 

2. Click  Flashback Table. 

Remove an object 

1. Select an object for purging in the Objects tab. 
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2. Click  Purge Object. 

3. Confirm deleting in the dialog window. 

Remove all objects 

1. Right-click anywhere in the Objects tab and choose Purge Recycle Bin from the pop-up menu. 

2. Confirm deleting in the dialog window. 

Remove all objects of any users 

1. Log in a user with SYSDBA privilege. 

2. Right-click anywhere in the Objects tab and choose Purge DBA Recycle Bin from the pop-up menu. 

3. Confirm deleting in the dialog window. 

Other Objects 

Navicat also allows you to manage other Oracle objects: Database Link, Index, Java, Materialized View Log, Sequence, 

Synonym, Trigger, Type, XML Schema, Directory, Public Database Link, Public Synonym and Tablespace. In the main 

window, click  Others and select an object to open the object list. 

Maintain Objects 

Navicat provides a complete solution for maintaining Oracle objects. 

1. In the main window, select objects in the Navigation pane or the Objects tab. 

2. Right-click the selected objects. 

3. Choose Maintain, and then choose a maintain option the from the pop-up menu. 

4. Results show in a pop-up window. 

Table 

Option Description 

Enable Table Lock Allow DDL operations on the table. 

Disable Table Lock Prevent DDL operations on the table. 

Enable Row Movement Allow the database to move a row, thus changing the rowid. 

Disable Row Movement Prevent the database from moving a row, thus preventing a change of rowid. 

Shrink Space Shrink space in the table. 

Move Relocate data of the table. 

Collect Statistics Analyze the contents of the table. 

Validate Structure Verify the integrity of the structure of the table. 

View 
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Option Description 

Compile Recompile the view specification or body. 

Procedure / Function 

Option Description 

Compile Recompile the specification or body. 

Compile for Debug Recompile the specification or body. Instruct the PL/SQL compiler to generate 

and store the code for use by the debugger. 

Index 

Option Description 

Rebuild Re-create the index or one of its partitions or subpartitions. 

Make Unusable Make the index unusable. 

Coalesce Merge the contents of index blocks where possible to free blocks for reuse. 

Compute Statistics Compute the statistics of the index. 

Monitoring Usage Begin monitoring the index. 

No Monitoring Usage Terminate monitoring the index. 

Java 

Option Description 

Compile or Resolve Resolve the primary Java class schema object. 

Set AuthID Current User Set the invoker rights to AUTHID CURRENT_USER. 

Set AuthID Definer Set the invoker rights to AUTHID DEFINER. 

Materialized View 

Option Description 

Enable Row Movement Allow the database to move a row, thus changing the rowid. 

Disable Row Movement Prevent the database from moving a row, thus preventing a change of rowid. 

Shrink Compact the materialized view segment. 

Compile Revalidate the materialized view. 

Force Refresh Fresh the materialized view. 

Materialized View Log 

Option Description 

Enable Row Movement Allow the database to move a row, thus changing the rowid. 

Disable Row Movement Prevent the database from moving a row, thus preventing a change of rowid. 

Shrink Space Compact the materialized view log segments. 

Package 

Option Description 

Compile Recompile the package specification and body. 
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Compile for Debug Recompile the package specification and body. Instruct the PL/SQL 

compiler to generate and store the code for use by the debugger. 

Trigger 

Option Description 

Enable Enable the trigger. 

Disable Disable the trigger. 

Compile Recompile the trigger. 

Compile for Debug Recompile the trigger. Instruct the PL/SQL compiler to generate and store the 

code for use by the debugger. 

Type 

Option Description 

Compile Recompile the type specification and body. 

Compile Debug Recompile the type specification and body. Instruct the PL/SQL compiler to 

generate and store the code for use by the debugger. 

XML Schema 

Option Description 

Compile Recompile the already registered XML schema. 

Purge Removes the XML schema completely from Oracle XML DB. 

Tablespace 

Option Description 

Read Only Place the tablespace in transition read-only mode. 

Read Write Allow write operations on a previously read-only tablespace. 

Online Take the tablespace online. 

Offline Take the tablespace offline. 

Coalesce Combine all contiguous free extents into larger contiguous extents for each 

datafile in the tablespace. 

Shrink Space Reduce the amount of space the tablespace is taking. 

 

PostgreSQL 

Databases & Schemas 

To start working with the server objects, you should create and open a connection. If the server is empty, you need to 

create a new database and/or a new schema. 

Create a new database 

1. In the Navigation pane, right-click a connection and choose New Database. 
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2. Enter the database properties in the pop-up window. 

Edit an existing database 

1. In the Navigation pane, right-click a database and choose Edit Database. 

2. Edit the database properties in the pop-up window. 

Create a new schema 

1. In the Navigation pane, right-click a database and choose New Schema. 

2. Enter the schema properties in the pop-up window. 

Edit an existing schema 

1. In the Navigation pane, right-click a schema and choose Edit Schema. 

2. Edit the schema properties in the pop-up window. 

Tables 

Tables are database objects that contain all data in a database. A table is a set of rows and columns, and their 

intersections are fields. In the main window, click  Table to open the table object list. 

You can create Normal / Foreign tables. Click the down arrow next to  New Table from the object toolbar and 

choose the table type. 

There are two ways to open a table with graphical fields, right-click a table and choose: 

Option Description 

Open Table Navicat loads all your BLOB fields (images) while opening the table. 

Open Table (Quick) Faster performance for opening the graphical table, as BLOB fields (images) will 

not be loaded until you click on the cell. (It is invisible by default until you hold 

down the SHIFT key when right-clicking the table.) 

To empty a table, right-click the selected table and choose Empty Table from the pop-up menu. This option is only 

applied when you wish to clear all the existing records without resetting the auto-increment value. To reset the 

auto-increment value while emptying your table, use Truncate Table. 

Table Designer 

Table Designer is the basic Navicat tool for working with tables. It allows you to create, edit and drop table's fields, 

indexes, foreign keys, and much more. 

In the Fields tab, you can search a field name by choosing Edit -> Find or pressing CTRL+F. When creating a new 

table, you are allowed to insert fields or rearrange the order of the fields. 

Note: The tabs and options in the designer depend on the server version and the table type. 
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Table Viewer 

When you open a table, Table Viewer displays data as a grid. Data can be displayed in two modes: Grid View and 

Form View. See Data Viewer for details. 

Views 

A view allows users to access a set of tables as if it is a single table. You can use views to restrict access to rows. In the 

main window, click  View to open the view object list. 

View Designer 

View Designer is the basic Navicat tool for working with views. You can edit the view definition as SQL statement 

(SELECT statement it implements) in the Definition tab. To customize the view of the editor and find out more features 

for SQL editing, see SQL Editor for details. If you want to load SQL statement from a SQL file to the editor, you can 

choose File -> Import SQL. 

Button Description 

 Preview Preview the data of the view. 

 Explain Show the Query Plan of the view. 

 View Builder Build the view visually. It allows you to create and edit views without knowledge of 

SQL. See SQL Builder for details. 

 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 

Hint: You can choose to show the preview results below the editor or in a new tab by selecting View -> Show Result 

-> Below Query Editor or In a New Tab. 

View Viewer 

When you open a view, View Viewer displays data as a grid. Data can be displayed in two modes: Grid View and Form 

View. See Data Viewer for details. 

Materialized Views 

Materialized Views are schema objects that used to summarize, compute, replicate, and distribute data. In the main 

window, click  Materialized View to open the materialized view object list. 

To refresh and completely replace the contents of a materialized view, right-click it in the Objects tab and select 

Refresh Materialized View With -> Data or No Data from the pop-up menu. 

Materialized View Designer 

Materialized View Designer is the basic Navicat tool for working with materialized views. You can edit the view 

definition as SQL statement (SELECT statement it implements) in the Definition tab. To customize the view of the 

editor and find out more features for SQL editing, see SQL Editor for details. If you want to load SQL statement from a 

SQL file to the editor, you can choose File -> Import SQL. 
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Button Description 

 Preview Preview the data of the materialized view. 

 Explain Show the Query Plan of the materialized view. 

 View Builder Build the materialized view visually. It allows you to create and edit materialized 

views without knowledge of SQL. See SQL Builder for details. 

 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 

Hint: You can choose to show the preview results below the editor or in a new tab by selecting View -> Show Result 

-> Below Query Editor or In a New Tab. 

Materialized View Viewer 

When you open a materialized view, Materialized View Viewer displays data as a grid. Data can be displayed in two 

modes: Grid View and Form View. See Data Viewer for details. 

Functions 

Functions are schema objects that consist a set of SQL statements and stored in the server. In the main window, click 

 Function to open the function object list. 

Function Wizard 

Click  New Function from the object toolbar. Function Wizard will pop up and it allows you to create a function 

easily. 

1. Define the parameters. Set the Mode, Type Schema, Type, Name and Default Value under the 

corresponding columns. 

2. Select the Schema and Return Type from the list. 

Hint: Once uncheck the Show wizard next time option, you can go to Options to enable it. 

Function Designer 

Function Designer is the basic Navicat tool for working with functions. You can enter a valid SQL statement in the 

Definition tab. This can be a simple statement such as SELECT or INSERT, or it can be a compound statement written 

using BEGIN and END. To customize the view of the editor and find out more features for SQL editing, see SQL Editor 

for details. 

Results 

To execute the function, click  Execute on the toolbar. If the SQL statement is correct, the statement will be 

executed and, if the statement is supposed to return data, the Result tab opens with the data returned. If an error 

occurs while executing the function, execution stops, the appropriate error message is displayed. If the function 

requires input parameters, the Input Parameter dialog will pop up. 

Note: Navicat supports to return 10 result sets. 
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Debug (Available only in Non-Essentials Edition) 

Before debugging PL/pgSQL functions, you need to install the pldbgapi extension. You can right-click anywhere in the 

function object list and select Install pldbgapi Extension. 

Note: This option is only available for PostgreSQL 9.1 or above. If your server is PostgreSQL 8.3 to 9.0, you need to 

enable the debugger plugin manually in the server. 

Then, open a PL/pgSQL function, click  Debug on the toolbar to launch the PostgreSQL Debugger. 

Types 

Types registers new data types for use in the current database. In the main window, click  Others -> Type to open 

the type object list. 

You can create Base / Composite / Enum / Range types. Click the down arrow next to  New Type from the object 

toolbar and choose the type. 

Type Designer 

Type Designer is the basic Navicat tool for working with types. It allows you to create or edit a type. 

Note: The tabs and options in the designer depend on the server version and the type you are chosen. 

Foreign Servers 

A foreign server typically encapsulates connection information that a foreign-data wrapper uses to access an external 

data resource. In the main window, click  Others -> Foreign Server to open the foreign server object list. 

To install the postgres_fdw extension for accessing data stored in external PostgreSQL servers, you can right-click 

anywhere in the foreign server object list and select Install postgres_fdw Extension. 

Foreign Server Designer 

Foreign Server Designer is the basic Navicat tool for working with foreign servers. It allows you to create or edit a 

foreign server. 

Other Objects 

Navicat also allows you to manage other PostgreSQL objects: Aggregate, Conversion, Domain, Index, Operator, 

Operator Class, Sequence, Trigger, Tablespace, Cast and Language. In the main window, click  Others and select 

an object to open the object list. 

Maintain Objects 

Navicat provides a complete solution for maintaining PostgreSQL objects. 

1. In the main window, select objects in the Navigation pane or the Objects tab. 
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2. Right-click the selected objects. 

3. Choose Maintain, and then choose a maintain option the from the pop-up menu. 

4. Results show in a pop-up window. 

Database 

Option Description 

Allow Users can connect to the database. 

Disallow No users can connect to the database. 

Analyze Database Collect statistics about the database. 

Vacuum Database Garbage-collect and optionally analyze the database. 

Reindex Database Recreate all indexes within the database. 

Table / Materialized View 

Option Description 

Analyze Tables / Analyze 

Materialized Views 

Collect statistics about the contents of the table. 

Vacuum Tables / Vacuum 

Materialized Views 

Garbage-collect and optionally analyze the table. 

Reindex Tables / Reindex 

Materialized Views 

Recreate all indexes of the table. 

SQLite 

Databases 

To start working with the server objects, you should create and open a connection. The database file set in the General 

tab of the Connection window is named as the main database. 

Attach a database file 

1. In the Navigation pane, right-click a connection and choose Attach Database. 

2. Enter the database properties in the pop-up window. 

Detach a database 

1. In the Navigation pane, right-click an attached database and choose Detach Database. 

Encrypt main database 

1. In the Navigation pane, right-click the main database and choose Encrypt Database. 

2. Enter the password in the pop-up window. 

Decrypt main database 
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1. In the Navigation pane, right-click the main database and choose Decrypt Database. 

2. Confirm decrypting in the dialog window. 

View the sqlite_master table 

1. In the Navigation pane, right-click a database and choose View Master Table. 

2. The sqlite_master table opens in Table Viewer. 

Tables 

Tables are database objects that contain all data in a database. A table is a set of rows and columns, and their 

intersections are fields. In the main window, click  Table to open the table object list. 

To empty a table, right-click the selected table and choose Empty Table from the pop-up menu. 

Table Designer 

Table Designer is the basic Navicat tool for working with tables. It allows you to create, edit and drop table's fields, 

indexes, foreign keys, and much more. 

In the Fields tab, you can search a field name by choosing Edit -> Find or pressing CTRL+F. 

Note: The tabs and options in the designer depend on the server version. 

Table Viewer 

When you open a table, Table Viewer displays data as a grid. Data can be displayed in two modes: Grid View and 

Form View. See Data Viewer for details. 

Views 

A view allows users to access a set of tables as if it is a single table. You can use views to restrict access to rows. In the 

main window, click  View to open the view object list. 

View Designer 

View Designer is the basic Navicat tool for working with views. You can edit the view definition as SQL statement 

(SELECT statement it implements) in the Definition tab. To customize the view of the editor and find out more features 

for SQL editing, see SQL Editor for details. If you want to load SQL statement from a SQL file to the editor, you can 

choose File -> Import SQL. 

Button Description 

 Preview Preview the data of the view. 

 Explain Show the Query Plan of the view. 

 View Builder Build the view visually. It allows you to create and edit views without 

knowledge of SQL. See SQL Builder for details. 
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 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 

Hint: You can choose to show the preview results below the editor or in a new tab by selecting View -> Show Result 

-> Below Query Editor or In a New Tab. 

View Viewer 

When you open a view, View Viewer displays data as a grid. Data can be displayed in two modes: Grid View and Form 

View. See Data Viewer for details. 

Other Objects 

Navicat also allows you to manage other SQLite objects: Index and Trigger. In the main window, click the 

corresponding button from the main toolbar to open the object list. 

Maintain Objects 

Navicat provides a complete solution for maintaining SQLite objects. 

1. In the main window, select objects in the Navigation pane or the Objects tab. 

2. Right-click the selected objects. 

3. Choose Maintain, and then choose a maintain option the from the pop-up menu. 

4. Results show in a pop-up window. 

Database 

Option Description 

Analyze Database Collect statistics about the database. 

Vacuum Database Rebuild the database file. It only works on the main database. 

Reindex Database Delete and recreate all indexes within the database. 

Table 

Option Description 

Analyze Tables Collect statistics about the contents of the table. 

Reindex Tables Delete and recreate all indexes of the table. 

Get Rows Count Count the number of rows in the table. 

Index 

Option Description 

Reindex Delete and recreate the index. 
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Chapter 6 - Data Viewer 

About Data Viewer 

Data Viewer displays the data as a grid or a form. It allows you to view, update, insert, or delete data. To switch the 

view, click  or  at the bottom. 

Note: Form View is available only in Non-Essentials Edition. 

The toolbar of Data Viewer provides the following functions for managing data: 

· Begin Transaction / Commit / Rollback 

Click  Begin Transaction to start a transaction. To make permanent all changes performed in the 

transaction, click  Commit. Or, click  Rollback to undo work done in the current transaction. 

If Auto Begin Transaction is enabled under Options, transaction will be started automatically when opening 

the data viewer. 

· Edit TEXT / BLOB / BFile 

Allow you to view and edit the content of TEXT, BLOB and BFile fields. 

Note: Only Oracle supports BFile. 

· Filter Data 

Allow you to filter records by creating and applying filter criteria for the data grid. 

· Sort Records 

Sort Records by custom order. 

· Import Data 

Import data from files. 

· Export Data 

Export data to files. 

Grid View & Form View 

Use Navigation Bar 

Data Viewer provides a convenient way to navigate among the records/pages using the Navigation Bar buttons. 
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Button Description 

 

New Record - enter a new record. At any point when you are working in the data 

viewer, click on this button to get a blank display for a record. 

 

Delete Record - delete an existing record. 

 

Apply Changes - apply the changes. 

 

Cancel Changes - remove all edits made to the current record. 

 

Refresh - refresh the data. 

 

Stop - stop when loading enormous data from server. 

 

First Page - move to first page. 

First Record - move to the first record. 

 

Previous Page - move to previous page. 

Previous Record - move one record back (if there is one) from the current record. 

 

Next Page - move to next page. 

Next Record - move one record ahead. 

 

Last Page - move to last page. 

Last Record - move to the last record. 

 

Limit Record Setting - set number of records showing on each page.  

 

Grid View - switch to grid view. 

 

Form View - switch to form view. 

Use the Limit Record Setting  button to enter to the edit mode. 

Limit Records  records per page 

Check this option if you want to limit the number of records showed on each page. Otherwise, all records will be 

displayed in one single page. And, set the value in the edit box. The number representing the number of records 

showed per page. 

Note: This setting mode will take effect on current object only. To adjust the global settings, see Options. 

 

Record a of b in page c 

The Record/Page Indicator displays the numbers representing the selected record and page. 

a - the selected record. 

b - number of records in the current page. 

c - the current page. 
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Edit Records 

The navigation bar allows you to switch the records quickly, insert, update or delete records. View data as a grid is 

most helpful for entering new records and editing old records in a table. 

To add a record 

1. Make sure that your cursor is situated in the first blank cell on the table, then enter the desired data. If you are 

adding the new record into an existing table, just simply click on an existing record and click  from the 

navigation bar or press CTRL+N to get a blank display for a record. 

2. Watch the graphics symbol in the record selectors box just to the left of your record. It will change from , 

which indicates that it is the current record, to , which indicates that you are editing this record. 

3. Just simply move to another record to save the record or click  from the navigation bar. 

To edit a record 

1. Select the record that you wish to edit by clicking in the specific field you want to change. 

2. Type in the new data for that field. 

3. Just simply move to another record, the new data will overwrite the previous data or click  from the 

navigation bar.  

Note: Close the table is another way to save the records. 

To edit multiple cells with same data 

1. Select a block of cells in the data grid. 

2. Type in the new data. 

Note: Changes will apply to multiple fields with compatible data type. 

To delete a record 

1. Select the record that you wish to delete. 

2. Just simply right-click and choose Delete Record or click  from the navigation bar. 

Edit Records with Special Handling 

To set the cell value to an empty string or NULL, right-click the selected cell and select Set to Empty String or Set to 

NULL. 

To view images in the grid, just simply choose View -> Display -> Show Image In Grid. 

Note: Available only for MySQL, Oracle, PostgreSQL and MariaDB. 
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Hint: To view/edit images in an ease way, see Image Editor. 

To edit a Date/Time record, just simply click  or press CTRL+ENTER to open the editor for editing. Choose/enter 

the desired data. The editor used in cell is determined by the field type assigned to the column. 

Note: Available only for MySQL, Oracle, PostgreSQL and MariaDB. 

Date Time DateTime/Timestamp 

 

 

 

To edit an Enum record, just simply choose the record from the drop-down list. 

Note: Available only for MySQL, PostgreSQL and MariaDB. 

 

To edit a Set record, just simply click  or press CTRL+ENTER to open the editor for editing. Select the records from 

the list. To remove the records, uncheck them in the same way. 

Note: Available only for MySQL and MariaDB. 

 

To view BFile content, just simply choose View -> Display -> Preview BFile. 

Note: Available only for Oracle. 
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To generate UUID, right-click the selected cell and choose Generate UUID. 

Note: Available only for PostgreSQL. 

Edit Records with Foreign Key (Foreign Key Data Selection - Available only in Non-Essentials Edition) 

Foreign Key Data Selection is a useful tool for letting you to get the available value from the reference table in an 

easy way. It allows you to show additional records from the reference table and search for particular records. 

To include data to the record, just simply click  or press CTRL+ENTER to open the editor for editing. 

 

Just simply double-click to select the desired data. 

Hint: By default, the number of records showed is 1000. To show all records, click . To refresh the records, click 

 or press F5. 

Click  to open a pane on the left for showing a list of column names. Just simply click to show the additional column. 

To remove the columns, uncheck them in the same way. 

 

Hint: To set column in ascending or descending mode, right-click anywhere on the column and select Sort -> Sort 

Ascending / Sort Descending. 

Enter a search string into the Filter edit box and press ENTER to filter for the particular records. 
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Hint: To remove the filter results, simply remove the search string and press ENTER. 

Copy Data from Navicat 

Data that being copied from Navicat goes into the clipboard with the fields delimited by tabs and the records delimited 

by carriage returns. It allows you to easily paste the clipboard contents into any application you want. Spreadsheet 

applications in general will notice the tab character between the fields and will neatly separate the clipboard data into 

rows and columns. 

To select data using keyboard shortcuts 

CTRL+A Toggle the selection of all rows and columns in the data grid. 

SHIFT+ARROW Toggle the selection of cells as you move up/down/left/right in the data grid. 

To select data using mouse actions 

· Select the desired records by holding down the CTRL key while clicking on each row. 

· Select a block of cells. 

Note: After you have selected the desired records, just simply press CTRL+C or right-click it and choose Copy. 

Paste Data into Navicat 

Data are copied into the clipboard will be arranged as below format: 

· Data are arranged into rows and column. 

· Rows and columns are delimited by carriage returns/tab respectively. 

· Columns in the clipboard have the same sequence as the columns in the data grid you have selected. 

When pasting data into Navicat, you can replace the contents of current records and append the clipboard data into the 

table. To replace the contents of current records in a table, you must select the cells in the data grid whose contents 

must be replaced by the data in the clipboard. Just simply press CTRL+V or right-click and choose the Paste from the 

pop-up menu. Navicat will paste all the content in the clipboard into the selected cells. The paste action cannot be 

undone if you do not enable transaction. 
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Copy Records as Insert/Update Statements 

To copy records as Insert/Update statement, right-click the selected records and choose Copy As -> Insert Statement 

or Update Statement. Then, you can paste the statements in any editors. 

Copy Field Name 

To copy field names as tab separated values, right-click the selected columns/data and choose Copy As -> Tab 

Separated Values (Field Name only) from the menu. If you want to copy data only or both field names and data, you 

can choose Tab Separated Values (Data only) or Tab Separated Values (Field Name and Data) respectively. 

Save Data as a File 

You can save the data in the table grid to a file. Simply right-click a cell and choose Save Data As. Enter the file name 

and file extension in the Save As dialog. 

Note: Not available when multiple selection. 

Sort / Find / Replace Records 

Sort Records 

Server stores records in the order they were added to the table. Sorting in Navicat is used to temporarily rearrange 

records, so that you can view or update them in a different sequence. 

Move over the column caption whose contents you want to sort by, click the right side of the column and select Sort 

Ascending, Sort Descending or Remove Sort. 

 

To sort by custom order of multi fields, click  Sort from the toolbar. 
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Find Records 

The Find bar is provided for quick searching for the text in the editor window. Just simply choose Edit -> Find or press 

CTRL+F. Then, choose Find Data and enter a search string. 

The search starts at the cursor's current position to the end of the file. There will not have differentiates when 

performing a uppercase or lowercase search. 

To find for the next text, just simply click Next or press F3. 

 

Replace Records 

To open the Replace bar, simply check the Replace box and enter the text you want to search and replace. 

Click Replace or Replace All to replace the first occurrence or all occurrences automatically. 
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If you clicked Replace All, you can click Apply to apply the changes or Cancel to cancel the changes. 

 

Find Columns 

To search a column, just simply choose Edit -> Find or press CTRL+F. Then, choose Find Column and enter a search 

string. 

 

Filter Records 

Use either of the following methods to filter the data in the grid: 

· Right-click a field and select Filter -> Field xxx Value from the pop-up menu to filter records by the current 

value of the selected column. 

· The Custom Filter dialog is provided for quick building a simple filter. Just simply right-click a field and select 

Filter -> Custom Filter from the pop-up menu. Use character '_' to represent any single symbol in the 

condition and use character '%' to represent any series of symbols in the condition. 

· You can also customize your filter in a more complicated way by right-clicking a field and selecting Filter ->  

Filter from the pop-up menu or clicking  Filter from the toolbar. The Filter Wizard becomes visible at the 

top of the grid, where you can see the active filtering condition and easily enable or disable it by clicking a 

check box at the left. 

Manipulate Raw Data 

Navicat normally recognize what user has input in grid as normal string, any special characters or functions would be 

processed as plain text (that is, its functionality would be skipped). 
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Editing data in Raw Mode provides an ease and direct method to apply server built-in functions. To access Raw Mode, 

just simply select View -> Display -> Raw Mode. 

Note: Available only for MySQL, PostgreSQL, SQLite and MariaDB. 

 

Format Data View 

Use the following methods to format the table grid: 

Move Columns 

1. Click on the column header and hold down the left mouse button. 

2. Move the pointer until a double black line appears in the desired location. 

3. Release the mouse and the column will move. 

 

Freeze Selected Column 

If there are many columns in the table and you want to freeze one or more columns to identify the record, just simply 

right-click the column you want to freeze and select Display -> Freeze Selected Column or select from the View 

menu. 

The frozen columns will move to the leftmost position in the table grid. This action will locks the frozen columns, 

preventing them from being edited. 

To unfreeze the columns, just simply right-click anywhere on the table grid and select Display -> Unfreeze Columns 

or select from the View menu. 

Set Column Width 

· Click right border at top of column and drag either left or right. 

· Double-click right border at top of column to obtain the best fit for the column. 

· Right-click the column you want to set the column width with and select Display -> Set Column Width or 

select from the View menu. Specify width in the Set Column Width dialog. 

Hint: The result only applies on the selected column. 

Set Row Height 



 61 

 

Right-click anywhere on the table grid and select Display -> Set Row Height or select from the View menu. Specify 

row height in the Set Row Height dialog. 

Hint: This action applies on the current table grid only. 

Show/Hide Columns 

If there are many columns in the table and you want to hide some of them from the table grid, just simply right-click 

anywhere on the table grid and select Display -> Show/Hide Columns or select from the View menu. Select the 

columns that you would like to hide. 

The hidden columns will disappear from the table grid. 

To unhide the columns, just simply right-click anywhere on the table grid and select Display -> Show/Hide Columns 

or select from the View menu. Select the columns that you would like to redisplay. 

 

Show/Hide ROWID 

If you want to display or hide the rowid (address) of every row, right-click anywhere on the table grid and select Display 

-> Show/Hide ROWID or select from the View menu. 

The ROWID column will be showed in the last column. 

Note: Available only for Oracle and SQLite. 

Assistant Editors 

Navicat provides powerful assistant editors to view and edit TEXT, BLOB, BFile and Dynamic Column fields content. 

The editor allows you to view, update, insert, or delete data in a table. Click  Text,  Hex,  Image,  Web 

and  Dynamic Column from the toolbar to activate the appropriate viewer/editor. 

Note: Oracle BFile fields cannot be edited. 

The Text pane allows you to edit data as a simple text. To change the syntax highlight, simply right-click the empty 

space and choose Language. Use the  button on the navigation bar to update the changed records to the table. 

The Hex pane allows you to edit data in hexadecimal mode. Use the  button on the navigation bar to update the 

changed records to the table. 

Note: Use the INSERT key on the keyboard to switch between Insert and Overwrite modes. 
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The Image pane allows you to show data as image. Use the  Load,  Save to disk and  Clear buttons to 

load/remove the image from a file, and save the image to a file. 

The Web pane allows you to show data with HTML codes as in a web browser. 

The Dynamic Column pane allows you to edit dynamic column data in MariaDB. Use the  and  buttons on the 

left to add and delete values. 

Filter Wizard 

Filter Wizard allows you to facilitate creating and applying filter criteria that you specify for the table grid. Moreover, it 

allows you to save filter criteria as a profile for future use. Click  Filter from the toolbar to activate the filter. 

 

1. To add a new condition to the criteria, just simply click <Add>. 

2. Click on the column box (next to the checkbox) and choose a table column. 

3. Click on the operator box (next to the column box) and choose a filter operator. You can choose Custom from 

the list to enter the condition manually. 

Filter Operator Result 

is equal to <?> My_Field = 'your_value' 

is not equal to <?> My_Field <> 'your_value' 

is less than <?> My_Field < 'your_value' 

is less than or equal to <?> My_Field <= 'your_value'  

is greater than <?> My_Field > 'your_value'  

is greater than or equal to <?> My_Field >= 'your_value' 

contains <?> My_Field LIKE '%your_value%' 

contains (case insensitive) <?> My_Field ILIKE '%your_value%' 
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Available only for PostgreSQL. 

does not contain <?> My_Field NOT LIKE '%your_value%' 

does not contain (case 

insensitive) <?> 

My_Field NOT ILIKE '%your_value%' 

Available only for PostgreSQL. 

begin with <?> My_Field LIKE 'your_value%' 

end with <?> My_Field LIKE '%your_value' 

is null My_Field IS NULL 

is not null My_Field IS NOT NULL 

is empty My_Field = '' 

is not empty My_Field <> '' 

is between <?> <?> ((My_Field >= your_value1) AND (My_Field <= your_value2)) 

is not between <?> <?> NOT ((My_Field >= your_value1) AND (My_Field <= 

your_value2)) 

is in list <?> My_Field IN ('aaa','bbb',...) 

is not in list <?> My_Field NOT IN ('aaa','bbb',...) 

4. Click on the criteria values box (next to the operator box) to activate the appropriate editor and enter the criteria 

values. The editor used in criteria values box is determined by the data type assigned to the corresponding 

column. 

5. Click on the logical operator box (next to the criteria values box) and choose and, or, and not, or not. 

6. Repeat step 1-5 to add another new condition. 

7. Click <Apply (Ctrl+R)> or press CTRL+R to see the result of the filtering you made. 

Hint: To set compound filter, simply right-click on a selected condition and choose Indent or Outdent. 

You are allowed to save filter criteria to and load them from profiles for future use. Just simply right-click on the Filter 

Wizard and select Open Profile, Save Profile, Save As or Delete Profile. 
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Chapter 7 - Query 

About Query 

A query is used to extract data from the database in a readable format according to the user's request. Navicat provides 

two powerful tools for working with the SQL queries: Query Editor for editing the query text directly and Query Builder 

for building queries visually. You can save your queries for setting automation tasks. In the main window, click  

Query to open the query object list. You also can click  New Query in the main toolbar to create a new query 

without opening any connections. 

Hint: Queries (.sql) are stored under the Settings Location. To open the folder, right-click a query and choose Open 

Containing Folder. If the connection is synchronized to Navicat Cloud, its queries are stored in the Cloud. 

Query Designer 

Button Description 

 Query Builder Open the SQL Builder for building queries visually. 

 Beautify SQL Format the codes with the Beautify SQL settings in Editor. 

 Text Activate the assistant editors for viewing and editing data. 

 Export Result Export the result of the query. 

 Run Execute the query: Run, Run current statement, or Run Selected 

(when highlighted SQL). 

 Stop Stop the executing query. 

 Explain Show the Query Plan of the query. 

Open an external SQL file in Navicat 

1. In the main window, click  New Query. 

2. In Query Designer, choose File -> Open External File. 

3. Select the file and choose the encoding. 

4. Click Open. 

Save an opened external SQL file as a Navicat query 

1. In Query Designer, choose File -> Save As Navicat Query. 

2. Enter the query name and choose the save location. 

3. Click OK. 

Save a Navicat query as an external SQL file 

1. In Query Designer, choose File -> Save As External File. 

2. Choose the save path and enter the file name. 
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3. Click Save. 

SQL Editor 

SQL Editor allows you to create queries and views. It allows you to create and edit SQL text, prepare and execute 

selected queries. You can define multiple SQL statements in one query window. Drag-and-drop or double-click an 

identifier in the right Identifiers pane to add it to the editor. 

Hint: SELECT statement will be automatically generated in SQL Editor while you build in SQL Builder. 

Navicat provides a wide range advanced features, such as compelling code editing capabilities, smart code-completion, 

SQL formatting, and more. 

SQL Formatting 

To change the SQL statement format, simply choose from the Format menu -  

Indent 

Increase/decrease indent for the selected lines of codes. 

Comment 

Comment/uncomment the selected lines of codes. 

Convert case 

Format the selected codes into upper/lower case. 

Beautify SQL (Available only in Non-Essentials Edition) 

Format the selected codes with the Beautify SQL settings. 

Beautify SQL With (Available only in Non-Essentials Edition) 

Change the SQL beautifier options. 

Option / Button Description 

Short brace length Set the length of the short brace. 

Upper case keywords Format all the SQL keywords to upper case. 

Beautify Save and apply the SQL beautifier options. 

Minify SQL (Available only in Non-Essentials Edition) 

Minify the format of the SQL in the SQL Editor. 

Code Completion (Available only in Non-Essentials Edition) 
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Code completion feature in Navicat pops up a list of suggestions as you type your SQL statement in the editor. It 

assists you with statement completion and the available properties of database objects, for example databases, tables, 

fields, views etc with their appropriate icons and information. You can update the code suggestions with latest 

database information by choosing Edit -> Code Completion -> Update code completion info. 

To invoke code completion, just simply press '.' for the available properties of database object currently in the scope. 

When the suggestion list appears, press TAB to insert the first item. You also can select the needed item using UPPER 

ARROW or DOWN ARROW and then press TAB or ENTER. 

 

In addition, code completion can be invoked by typing a character or pressing ESC on your keyboard for SQL 

keywords/database objects. 

If you select a snippet name from the list, the saved code will be inserted to the editor. 

 

Hint: Resize the suggestion list by dragging the lower right corner. 

You can enable or disable the code completion feature in Options. 

Code Folding 

Code folding feature enables you to collapse blocks of code such that only the first line of the block appears in SQL 

Editor. 

A block of code that can be folded is indicated by an icon  to the left of the first line of the block. A vertical line 

extends from the icon to the bottom of the foldable code. In contrast, a folded block of code is indicated by an icon  

to left of the code block. You can fold the block by clicking  or expand it by clicking . 


















































































































































































